Site Seals to be disabled for connections using TLS1.0 or below

  Print
As technology advances it becomes necessary to stop using older security technology. As part of this program there are some changes to site seals for Geotrust, Thawte and Symantec HTTPS Certificates.

By the end of August 2016 site seals will only appear if the connection to the site is using TLS1.1 or higher. If the connection is established using TLS1.0 or below the seal will not display.

As a website owner you must ensure your server supports TLS1.1/1.2. You can check how good your HTTPS installation is using the SSL Labs checker.

This program is to maintain the integrity of site seals to ensure visitors can trust the website they are visiting is using the latest encryption technologies.

Please note support for TLS1.1/1.2 is enabled in all certificates. This is a server side configuration and does not require a certificate re-issuance.


Related Articles